#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w\.]+@[\w\.]+\.\w+"
Local $sString = "send : .host@server.com" & @CRLF & _
"recv : guest@client.com" & @CRLF & _
"return : admin_1@test.server.com" & @CRLF & _
"fwd : admin.programming@test.server.co.kr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")