package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w\.]+@[\w\.]+\.\w+`)
var str = `send : .host@server.com
recv : guest@client.com
return : admin_1@test.server.com
fwd : admin.programming@test.server.co.kr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}