import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\.]+@[\\w\\.]+\\.\\w+";
final String string = "send : .host@server.com\n"
+ "recv : guest@client.com\n"
+ "return : admin_1@test.server.com\n"
+ "fwd : admin.programming@test.server.co.kr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}