// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w\.]+@[\w\.]+\.\w+").unwrap();
let string = "send : .host@server.com
recv : guest@client.com
return : admin_1@test.server.com
fwd : admin.programming@test.server.co.kr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}