# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<upc>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<date>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<batch>[\d,a-z,A-Z]{1,70}))//gm;t' <<< "(01)30628242248564(13)220909(10)8563220909"