$re = '/(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<upc>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<date>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<batch>[\d,a-z,A-Z]{1,70}))/m';
$str = '(01)30628242248564(13)220909(10)8563220909';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;