import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<upc>[\\d,a-z,A-Z]{1,70}))(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<date>[\\d,a-z,A-Z]{1,70}))(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<batch>[\\d,a-z,A-Z]{1,70}))";
final String string = "(01)30628242248564(13)220909(10)8563220909";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}