const regex = /(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<upc>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<date>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<batch>[\d,a-z,A-Z]{1,70}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<upc>[\\d,a-z,A-Z]{1,70}))(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<date>[\\d,a-z,A-Z]{1,70}))(\\(\\d{1,3}[0-9,a-z,A-Z]{1}?\\)(?<batch>[\\d,a-z,A-Z]{1,70}))', 'gm')
const str = `(01)30628242248564(13)220909(10)8563220909`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);