// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<upc>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<date>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<batch>[\d,a-z,A-Z]{1,70}))").unwrap();
let string = "(01)30628242248564(13)220909(10)8563220909";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}