#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((\d)\2{2,})|\d(\d)\3(?!\3)\d"
Local $sString = "1234566778" & @CRLF & _
"12334566" & @CRLF & _
"1234566678" & @CRLF & _
"1222" & @CRLF & _
"2221" & @CRLF & _
"66" & @CRLF & _
"122" & @CRLF & _
"221" & @CRLF & _
"111" & @CRLF & _
"12345654554888"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")