const regex = /((\d)\2{2,})|\d(\d)\3(?!\3)\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d)\\2{2,})|\\d(\\d)\\3(?!\\3)\\d', 'g')
const str = `1234566778
12334566
1234566678
1222
2221
66
122
221
111
12345654554888`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}