import Foundation
let pattern = #"((\d)\2{2,})|\d(\d)\3(?!\3)\d"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234566778
12334566
1234566678
1222
2221
66
122
221
111
12345654554888
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)