re = /((\d)\2{2,})|\d(\d)\3(?!\3)\d/
str = '1234566778
12334566
1234566678
1222
2221
66
122
221
111
12345654554888'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end