using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d)\2{2,})|\d(\d)\3(?!\3)\d";
string input = @"1234566778
12334566
1234566678
1222
2221
66
122
221
111
12345654554888";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}