using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))";
string input = @" setItems(Item[] items)
setItems(List<Item> items)
setItems(Item[])
setItems(List<Item>)
setItems(int items) item
+getItems()* Item[]
+getItems(List<Item> items)* List<Item>
(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[?\]?)?|(\w+\<?\w+?\>?))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}