$re = '/(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))/m';
$str = ' setItems(Item[] items)
setItems(List<Item> items)
setItems(Item[])
setItems(List<Item>)
setItems(int items) item
+getItems()* Item[]
+getItems(List<Item> items)* List<Item>
(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|$])?\\s?((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);