const regex = /(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|$])?\\s?((\\w+\\[\\])?|(\\w+\\<\\w+\\>)?|(\\w+))', 'gm')
const str = ` setItems(Item[] items)
setItems(List<Item> items)
setItems(Item[])
setItems(List<Item>)
setItems(int items) item
+getItems()* Item[]
+getItems(List<Item> items)* List<Item>
(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|\$])?\\s?((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}