// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))").unwrap();
let string = " setItems(Item[] items)
setItems(List<Item> items)
setItems(Item[])
setItems(List<Item>)
setItems(int items) item
+getItems()* Item[]
+getItems(List<Item> items)* List<Item>
(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|$])?\\s?((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}