re = /(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))/m
str = ' setItems(Item[] items)
setItems(List<Item> items)
setItems(Item[])
setItems(List<Item>)
setItems(int items) item
+getItems()* Item[]
+getItems(List<Item> items)* List<Item>
(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|$])?\\s?((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end