import re
regex = re.compile(r"(\+|-|~|#)?(\w+)\(((\w+\[?\]?)?|(\w+\<?\w+?\>?)?)\s?(\w+)?\)([*|$])?\s?((\w+\[\])?|(\w+\<\w+\>)?|(\w+))", flags=re.MULTILINE)
test_str = (" setItems(Item[] items)\n"
" setItems(List<Item> items)\n"
" setItems(Item[])\n"
" setItems(List<Item>)\n"
" setItems(int items) item\n"
" +getItems()* Item[]\n"
" +getItems(List<Item> items)* List<Item>\n\n\n"
"(\\+|-|~|#)?(\\w+)\\(((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?)?)\\s?(\\w+)?\\)([*|$])?\\s?((\\w+\\[?\\]?)?|(\\w+\\<?\\w+?\\>?))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")