#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)src="(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))""
Local $sString = "<p><img src="http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png"></p>" & @CRLF & _
"<p><img src="http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif"></p>" & @CRLF & _
"<p><img src="http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg"></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")