using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=""(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))""";
string input = @"<p><img src=""http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png""></p>
<p><img src=""http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif""></p>
<p><img src=""http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg""></p>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}