import re
regex = re.compile(r"src=\"(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))\"", flags=re.IGNORECASE)
test_str = ("<p><img src=\"http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png\"></p>\n"
"<p><img src=\"http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif\"></p>\n"
"<p><img src=\"http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg\"></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")