// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)src="(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))""#).unwrap();
let string = "<p><img src=\"http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png\"></p>
<p><img src=\"http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif\"></p>
<p><img src=\"http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg\"></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}