re = /src="(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))"/i
str = '<p><img src="http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png"></p>
<p><img src="http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif"></p>
<p><img src="http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg"></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end