const regex = /src="(http:\/\/|https:\/\/)(\S*\.(gif|png|jpg|jpeg))"/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="(http:\\\/\\\/|https:\\\/\\\/)(\\S*\\.(gif|png|jpg|jpeg))"', 'gi')
const str = `<p><img src="http://cdn03.XXXXXX.de/upload2/Q/m/QmOJ0Li2UbIl143705410063P4391.png"></p>
<p><img src="http://cdn02.XXXXXX.de/upload2/i/Q/iQtReUOqw1Jf143705410914P4391.gif"></p>
<p><img src="http://cdn03.XXXXXX.de/upload2/5/D/5Dse28yAh160143705411823P4391.jpg"></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}