using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=p)\d+|(?<=mim)\d+";
string input = @"3/1/1/10=p3 12/mim1=eth11
3/1/1/11=p4 12/mim3=eth11
3/1/1/1=p1 12/mim2=eth11
3/1/1/12=p5 13/mim1=eth11
3/1/1/13=p6 13/mim3=eth11
3/1/1/2=p2 13/mim2=eth11
8/mim1=eth11 3/1/2/5=p7
8/mim2=eth11 3/1/2/6=p8
3/1/2/11=p9 4/mim1=eth11";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}