import Foundation
let pattern = #"(?<=p)\d+|(?<=mim)\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
3/1/1/10=p3 12/mim1=eth11
3/1/1/11=p4 12/mim3=eth11
3/1/1/1=p1 12/mim2=eth11
3/1/1/12=p5 13/mim1=eth11
3/1/1/13=p6 13/mim3=eth11
3/1/1/2=p2 13/mim2=eth11
8/mim1=eth11 3/1/2/5=p7
8/mim2=eth11 3/1/2/6=p8
3/1/2/11=p9 4/mim1=eth11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)