const regex = /(?<=p)\d+|(?<=mim)\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=p)\\d+|(?<=mim)\\d+', 'g')
const str = `3/1/1/10=p3 12/mim1=eth11
3/1/1/11=p4 12/mim3=eth11
3/1/1/1=p1 12/mim2=eth11
3/1/1/12=p5 13/mim1=eth11
3/1/1/13=p6 13/mim3=eth11
3/1/1/2=p2 13/mim2=eth11
8/mim1=eth11 3/1/2/5=p7
8/mim2=eth11 3/1/2/6=p8
3/1/2/11=p9 4/mim1=eth11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}