import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=p)\\d+|(?<=mim)\\d+";
final String string = "3/1/1/10=p3 12/mim1=eth11\n"
+ "3/1/1/11=p4 12/mim3=eth11\n"
+ "3/1/1/1=p1 12/mim2=eth11\n\n\n"
+ "3/1/1/12=p5 13/mim1=eth11\n"
+ "3/1/1/13=p6 13/mim3=eth11\n"
+ "3/1/1/2=p2 13/mim2=eth11\n\n"
+ "8/mim1=eth11 3/1/2/5=p7\n"
+ "8/mim2=eth11 3/1/2/6=p8\n\n"
+ "3/1/2/11=p9 4/mim1=eth11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}