# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=p)\d+|(?<=mim)\d+"
test_str = ("3/1/1/10=p3 12/mim1=eth11\n"
"3/1/1/11=p4 12/mim3=eth11\n"
"3/1/1/1=p1 12/mim2=eth11\n\n\n"
"3/1/1/12=p5 13/mim1=eth11\n"
"3/1/1/13=p6 13/mim3=eth11\n"
"3/1/1/2=p2 13/mim2=eth11\n\n"
"8/mim1=eth11 3/1/2/5=p7\n"
"8/mim2=eth11 3/1/2/6=p8\n\n"
"3/1/2/11=p9 4/mim1=eth11")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.