#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([5-9]\d{1}\d*|\d{3}\d*)$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"33" & @CRLF & _
"49" & @CRLF & _
"50" & @CRLF & _
"51" & @CRLF & _
"60" & @CRLF & _
"77" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"101" & @CRLF & _
"102" & @CRLF & _
"999" & @CRLF & _
"444" & @CRLF & _
"333" & @CRLF & _
"9999" & @CRLF & _
"10001" & @CRLF & _
"10000" & @CRLF & _
"10930" & @CRLF & _
"10903" & @CRLF & _
"11022" & @CRLF & _
"11014" & @CRLF & _
"11099" & @CRLF & _
"11100" & @CRLF & _
"11111" & @CRLF & _
"11562" & @CRLF & _
"11234" & @CRLF & _
"12453" & @CRLF & _
"22222" & @CRLF & _
"232312" & @CRLF & _
"200000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")