// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([5-9]\d{1}\d*|\d{3}\d*)$").unwrap();
let string = "1
12
33
49
50
51
60
77
99
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
11111
11562
11234
12453
22222
232312
200000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}