use strict;
my $str = '1
12
33
49
50
51
60
77
99
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
11111
11562
11234
12453
22222
232312
200000
';
my $regex = qr/^([5-9]\d{1}\d*|\d{3}\d*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}