re = /^([5-9]\d{1}\d*|\d{3}\d*)$/m
str = '1
12
33
49
50
51
60
77
99
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
11111
11562
11234
12453
22222
232312
200000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end