import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([5-9]\\d{1}\\d*|\\d{3}\\d*)$";
final String string = "1\n"
+ "12\n"
+ "33\n"
+ "49\n"
+ "50\n"
+ "51\n"
+ "60\n"
+ "77\n"
+ "99\n"
+ "100\n"
+ "101\n"
+ "102\n"
+ "999\n"
+ "444\n"
+ "333\n"
+ "9999\n"
+ "10001\n"
+ "10000\n"
+ "10930\n"
+ "10903\n"
+ "11022\n"
+ "11014\n"
+ "11099\n"
+ "11100\n"
+ "11111\n"
+ "11562\n"
+ "11234\n"
+ "12453\n"
+ "22222\n"
+ "232312\n"
+ "200000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}