const regex = /^([5-9]\d{1}\d*|\d{3}\d*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([5-9]\\d{1}\\d*|\\d{3}\\d*)$', 'gm')
const str = `1
12
33
49
50
51
60
77
99
100
101
102
999
444
333
9999
10001
10000
10930
10903
11022
11014
11099
11100
11111
11562
11234
12453
22222
232312
200000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}