#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)"
Local $sString = "Opp foobar, foocity" --> Must match "Opp foobar"" & @CRLF & _
"Fooplace, near barplace, barcity" --> Must match "near barplace"" & @CRLF & _
"Fooplace, Shoppers Stop, foocity"--> Must match nothing" & @CRLF & _
"Fooplace, opp barplace"--> Must match "opp barplace"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")