using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)";
string input = @"Opp foobar, foocity"" --> Must match ""Opp foobar""
Fooplace, near barplace, barcity"" --> Must match ""near barplace""
Fooplace, Shoppers Stop, foocity""--> Must match nothing
Fooplace, opp barplace""--> Must match ""opp barplace""
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}