re = /(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)/mi
str = 'Opp foobar, foocity" --> Must match "Opp foobar"
Fooplace, near barplace, barcity" --> Must match "near barplace"
Fooplace, Shoppers Stop, foocity"--> Must match nothing
Fooplace, opp barplace"--> Must match "opp barplace"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end