const regex = /(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)', 'gmi')
const str = `Opp foobar, foocity" --> Must match "Opp foobar"
Fooplace, near barplace, barcity" --> Must match "near barplace"
Fooplace, Shoppers Stop, foocity"--> Must match nothing
Fooplace, opp barplace"--> Must match "opp barplace"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}