import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)";
final String string = "Opp foobar, foocity\" --> Must match \"Opp foobar\"\n"
+ "Fooplace, near barplace, barcity\" --> Must match \"near barplace\"\n"
+ "Fooplace, Shoppers Stop, foocity\"--> Must match nothing\n"
+ "Fooplace, opp barplace\"--> Must match \"opp barplace\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}