#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s?\((.+?)\)\s?"
Local $sString = "text1((text2))text2"
Local $sSubst = " ($1) "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)