// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s?\((.+?)\)\s?").unwrap();
let string = "text1((text2))text2";
let substitution = " ($1) ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}