package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s?\((.+?)\)\s?`)
var str = `text1((text2))text2`
var substitution = " ($1) "
fmt.Println(re.ReplaceAllString(str, substitution))
}