import Foundation
let pattern = #"\s?\((.+?)\)\s?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"text1((text2))text2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" ($1) "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)