const regex = /\s?\((.+?)\)\s?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?\\((.+?)\\)\\s?', 'g')
const str = `text1((text2))text2`;
const subst = ` ($1) `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);