#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "trans\('([a-zA-Z]+[.])+(testword|testword2|testword1|testword3)'\)"
Local $sString = "Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!" & @CRLF & _
"" & @CRLF & _
"Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save Favorites & Share expressions with friends or the Community. Explore your results with Tools. A full Reference & Help is available in the Library, or watch the video Tutorial." & @CRLF & _
"" & @CRLF & _
"Sample text for testing:" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789 _+-.,!@#$%^&*();\/|<>"'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net bar.ba@test.co.uk" & @CRLF & _
"www.demo.com http://foo.co.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar" & @CRLF & _
"https://mediatemple.net" & @CRLF & _
"" & @CRLF & _
"trans('asd.asd.testword')" & @CRLF & _
"trans('asddd.asd.asd.testword1')" & @CRLF & _
"trans('asggfd.asd.asd.asd.asd.testword2')" & @CRLF & _
"trans('asdrtd.testword3')" & @CRLF & _
"" & @CRLF & _
"((^|, )(part1|part2|part3))+$"
Local $sSubst = "trans('common.$2')"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)