# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"trans\('([a-zA-Z]+[.])+(testword|testword2|testword1|testword3)'\)"
test_str = ("Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!\n\n"
"Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save Favorites & Share expressions with friends or the Community. Explore your results with Tools. A full Reference & Help is available in the Library, or watch the video Tutorial.\n\n"
"Sample text for testing:\n"
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"0123456789 _+-.,!@#$%^&*();\\/|<>\"'\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"555.123.4567 +1-(800)-555-2468\n"
"foo@demo.net bar.ba@test.co.uk\n"
"www.demo.com http://foo.co.uk/\n"
"http://regexr.com/foo.html?q=bar\n"
"https://mediatemple.net\n\n"
"trans('asd.asd.testword')\n"
"trans('asddd.asd.asd.testword1')\n"
"trans('asggfd.asd.asd.asd.asd.testword2')\n"
"trans('asdrtd.testword3')\n\n"
"((^|, )(part1|part2|part3))+$")
subst = "trans('common.$2')"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.