import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "trans\\('([a-zA-Z]+[.])+(testword|testword2|testword1|testword3)'\\)";
final String string = "Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!\n\n"
+ "Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with ctrl-z. Save Favorites & Share expressions with friends or the Community. Explore your results with Tools. A full Reference & Help is available in the Library, or watch the video Tutorial.\n\n"
+ "Sample text for testing:\n"
+ "abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "0123456789 _+-.,!@#$%^&*();\\/|<>\"'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "555.123.4567 +1-(800)-555-2468\n"
+ "foo@demo.net bar.ba@test.co.uk\n"
+ "www.demo.com http://foo.co.uk/\n"
+ "http://regexr.com/foo.html?q=bar\n"
+ "https://mediatemple.net\n\n"
+ "trans('asd.asd.testword')\n"
+ "trans('asddd.asd.asd.testword1')\n"
+ "trans('asggfd.asd.asd.asd.asd.testword2')\n"
+ "trans('asdrtd.testword3')\n\n"
+ "((^|, )(part1|part2|part3))+$";
final String subst = "trans('common.$2')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}